Working with the different Views in the SCM application

Use the software configuration management (SCM) application in the HCL OneTest™ API Tools window to work with HCL OneTest API projects.

To run the SCM application in the HCL OneTest API Tools window, click File > Source Control.

By default, four views are displayed in the SCM application: You can display other views by clicking Window > Show View > Other and selecting a view.

To update the contents of the SCM application, click File > Source Control in the HCL OneTest API window. This is the only way to refresh the view in the SCM application.

When you are working in a project under software configuration management, it is useful to return to the SCM application to review any changes or conflicts, for example, if another user opened the same project. Add any new resources to a project manually. Keep your project up to date by clicking File > Source Control, and review any changes in the Synchronize view of the SCM application. If any resources in your project are unsaved, click the Save All button .

You can update incoming changes and commit outgoing changes by using the toolbar in the Synchronize view. Committed changes are displayed in the repository, and incoming updates are displayed in your open project.

Synchronize view

The Synchronize view displays the current project, highlighting any changes or conflicts that exist between the project and the version in the repository.

The toolbar in the Synchronize view provides icons representing commands to navigate the project tree and resolve differences in the project.

Icon Description
Switch between opened projects or open/synchronize with another project.
Pins the current synchronization.
Expands the entire project tree.
Moves to the next difference in the project.
Moves to the previous difference in the project.
Collapses the entire project tree.
Incoming mode shows changes that are made outside of the HCL OneTest API project (for example, by other users).
Outgoing mode shows uncommitted changes that are made in your project.
Incoming/Outgoing mode shows incoming and outgoing changes.
Conflicts mode shows conflicts between the project and the repository.
Updates all incoming changes to the project.
Commits all outgoing changes to the repository.
Toggles the display of change sets in the synchronization tree.

Navigator view

Use the Navigator view to browse the contents of all projects in the selected repository and show the status of each item.

The project resources are locally saved in the HCL OneTest API Tools workspace. For example, the default workspace location in Windows is Windows_user_directory\.integrationtester\eclipse\GHTools\workspace. To find the location of the resource in the local workspace, right-click the project in the Navigator view, and click Properties.

Console view

The Console view displays status and error messages for basic operations in the SCM application (for example, sharing a project, updating changes, committing changes).

History view


The History view shows the revision history of a selected item in the Synchronize view or Navigator view. You can view the history of an item by right-clicking the item and selecting Show History.

Feedback