Running POM files from earlier versions of HCL OneTest™ API

POM files generated from earlier versions of HCL OneTest™ API cannot run with HCL OneTest™ API 9.2.1 or later. To use POM files generated from earlier versions of HCL OneTest™ API you must edit the existing POM file. POM files generated from HCL OneTest™ API 9.2.1.1 or later can run a Maven command to update the version property value. Alternatively, you can create a new POM file with the current release.

Running a Maven command

You must run the following Maven command if you want to update POM files generated from HCL OneTest™ API 9.2.1.1 or later.

mvn versions:update-property -Dproperty=it-plugin-version -f <name of pom file>

To back up the existing POM file, find the new version from HCL Quality Server and update the version in the existing POM file.

The following example shows the Maven command to update the existing POM file named pom_tp52776.xml.

mvn versions:update-property -Dproperty=it-plugin-version -f pom_tp52776.xml

This command creates a backup of the file and updates the version in the pom_tp52776.xml from 1.920.0 to 1.921.1

Editing the existing POM file

For POM files generated from earlier versions of HCL OneTest™ API edit the earlier POM file by replacing the version number in the old POM file (for example, 1.911.1 for HCL Quality Server version 9.1.1.1) with the version number from HCL Quality Server 9.2.1 (for example, 1.921.0).

Note: You can find the version for the current release by generating a POM file and by looking at the version property of that generated POM file.

The following example shows a section of a new POM file generated from HCL OneTest™ API 9.2.1:

    <dependencies>
        <dependency>
            <groupId>com.hcl.products.test.it</groupId>
            <artifactId>it-plugin-boot</artifactId>
            <version>1.921.0</version>
            <scope>test</scope>
        </dependency>
    </dependencies>
    <build>
        <plugins>
            <plugin>
                <groupId>com.hcl.products.test.it</groupId>
                <artifactId>it-plugin</artifactId>
                <version>1.921.0</version>

The following example shows a section of an existing POM file that was generated from HCL OneTest™ API 9.2.0:

    <dependencies>
        <dependency>
            <groupId>com.hcl.products.test.it</groupId>
            <artifactId>it-plugin-boot</artifactId>
            <version>1.920.0</version>
            <scope>test</scope>
        </dependency>
    </dependencies>
    <build>
        <plugins>
            <plugin>
                <groupId>com.hcl.products.test.it</groupId>
                <artifactId>it-plugin</artifactId>
                <version>1.920.0</version>

Note the value of the version property (<version></version> in each of the POM files. To run the existing POM file with HCL OneTest™ API 9.2.1, you must edit the version of the existing POM file and change it from 1.920.0 to 1.921.0.

Note: If you generated a Failsafe plug-in POM file from an earlier version of HCL OneTest™ API, you must change the version number in three places.
    <dependencies>
        <dependency>
            <groupId>com.hcl.products.test.it</groupId>
            <artifactId>it-plugin-boot</artifactId>
            <version>1.920.0</version>
            <scope>test</scope>
        </dependency>
    </dependencies>
    <build>
        <plugins>
            <plugin>
                <groupId>com.hcl.products.test.it</groupId>
                <artifactId>it-plugin</artifactId>
                <version>1.920.0</version>
...
            </plugin>
            <plugin>
...
                <dependencies>
                    <dependency>
                        <groupId>com.hcl.products.test.it</groupId>
                        <artifactId>it-surefire-provider</artifactId>
                        <version>1.920.0</version>
                    </dependency>
                </dependencies>
Feedback