WebSphere MQ software requirements

You should be aware of certain software requirements for using IBM® WebSphere® MQ for HCL OneTest™ API.

WebSphere libraries

To enable HCL OneTest API to work with WebSphere MQ, use HCL OneTest API Library Manager to specify the locations of the HCL libraries that are used for accessing WebSphere MQ.

The following versions of IBM WebSphere MQ are supported:
  • WebSphere MQ 7.1 and 7.5
  • WebSphere MQ 8.0
  • WebSphere MQ 9.0
Note:

Different versions of those libraries can be required depending on the version of WebSphere MQ being used. HCL OneTest API Library Manager lists the required libraries that are required for each version of WebSphere MQ and also the default location that HCL OneTest API looks out for. The default location for the specified libraries can be modified in the Library Manager.

For more information, see Working with the Library Manager.

JMS interface libraries (optional)

The JMS interface can be used to interact with WebSphere MQ.

For more information about JMS, visit the Oracle website. For more information about WebSphere MQ JMS, refer to WebSphere MQ documentation.

To use the JMS interface to access WebSphere MQ, create (if necessary) a new provider (under WebSphere MQ) in Library Manager and specify the locations of the relevant libraries.

Different versions of those libraries can be required depending on the version of WebSphere MQ being used. HCL OneTest API Library Manager lists the required libraries that are required for each version of WebSphere MQ and also the default location that HCL OneTest API looks out for. The default location for the specified libraries can be modified in the HCL OneTest API Library Manager.

For more information, see Working with the Library Manager.

Feedback