IBM Integration Bus requirements

Review the software requirements for using IBM® Integration Bus (formerly WebSphere® Message Broker) with HCL OneTest™ API.
The following table lists the software requirements.
Software requirement Description

HCL OneTest API 8.5.x to 8.6.x

HCL OneTest API 8.5.x to 8.6.x includes the required client libraries for WebSphere Message Broker. These libraries can connect to WebSphere Message Broker 7.0.x and 8.0.x, so you do not need to use Library Manager to configure any WebSphere Message Broker libraries.

HCL OneTest API 8.7.0 or later

HCL OneTest API 8.7.0 or later contains libraries for IBM Integration Bus. These libraries can connect to IBM Integration Bus 9.0.x and 10.0.x, so you do not need to use Library Manager to configure any IBM Integration Bus libraries.

WebSphere Message Broker 7.0.x, 8.0.x

or

IBM Integration Bus 9.0.x, 10.0

Several versions of WebSphere Message Broker and IBM Integration Bus are supported by HCL OneTest API.

For information about IBM Integration Bus, see the related documentation in IBM Knowledge Center.

IBM WebSphere MQ 7.1.x, 7.5.x, 8.0.x, 9.0.x.

During synchronization, communication between HCL OneTest API and IBM Integration Bus is performed using a WebSphere MQ queue manager, so you need access to a WebSphere MQ installation if you want to use HCL OneTest API with IBM Integration Bus.

To enable HCL OneTest API to connect to WebSphere MQ, you must use Library Manager to configure the required WebSphere MQ client libraries.

For information about Library Manager, see WebSphere MQ software requirements and Working with the Library Manager.

For information about WebSphere MQ, see the related documentation in IBM Knowledge Center.

Feedback