Requirements for RabbitMQ

To use RabbitMQ messaging with HCL OneTest™ API, you require specific software and product libraries.

Software requirements

To use RabbitMQ messaging with HCL OneTest API, you must install and configure the following software:
  • RabbitMQ client 5.3 or later
  • RabbitMQ server 3.7.5 or later

For more information about RabbitMQ software, see the RabbitMQ website.

RabbitMQ client libraries

To connect to the RabbitMQ client, you must configure the following libraries in the HCL OneTest API Library Manager utility:
  • amqp-client-5.3.0.jar
  • metrics_core-3.1.0.jar
  • micrometer-core-1.0.0.jar
  • slf4j-api-1.7.25.jar
  • slf4j-jdk14-1.7.25.jar
By default, you can find the required files in the following location: C:\rabbitmq\client\5.3\lib.
Note: You can modify the default locations for the specified libraries by using the Library Manager. For more information, see Working with the Library Manager.
Feedback